Jetson Nano | Grüne Status LED aber kein Bild / Funktion

There are 13 replies in this Thread which has previously been viewed 1,731 times. The latest Post (September 12, 2023 at 1:33 PM) was by Viator.

  • Hallo Zusammen,
    bin neu und wusste nicht genau, wo ich das Thema einsortieren soll. Bitte seht es mir daher nach, wenn das Thema in einem anderen Bereich besser passen sollte. Aber zu meinem Problem:

    Habe seit einigen Tagen ein Jetson Nano 4G und damit die ersten Versuche gemacht. Zuerst habe ich das Image von nVidia auf die SD Karte gespielt und damit mal ein wenig herum gespielt. Stromversorgung lief über Micro-USB (bis 2A gemessen). Keine Probleme.

    Habe dann das Belabos Image heruntergeladen (https://belabox.net/) und ebenfalls auf die SD Karte gepackt. Hat funktioniert. Das Jetson Nano hat gebootet und über den per HDMI angeschlossenen Bildschirm gezeigt, man möge sich in das Webinterface anmelden.

    Als nächstes habe ich das Jetson Nano herunter gefahren (Power-Taste am Case) und wollte es später wieder hochfahren.

    Seit dem sagt das Teil keinen Mucks mehr. Heißt: Grüne Status LED leuchtet, Gerät macht aber nichts mehr. Kühlkörper bleibt kalt, Keine Ausgabe am HDMI/DP und gemessener Stromverbrauch liegt bei 0.8 - 1W

    Habe folgende Stromversorgungen getestet:

    Micro USB + Powerbank (Jumper nicht gesteckt, hatte bei den ersten Tests funktioniert, jetzt nicht mehr)

    Micro USB an QC3.0 Netzteil (Jumper ebenfalls nicht gesteckt, hatte ebenfalls funktioniert)

    Power Jack an 8A@5V Netzteil (Jumper auf PCB gesteckt)

    Power Jack an PD Trigger (Jumper auf PCB gesteckt)

    Leider habe ich keine Ahnung, was ich falsch gemacht haben soll.

    Habe folgenden Thread bei nVidia gefunden: https://forums.developer.nvidia.com/t/jetson-nano-…-green/237468/6

    Steht irgendjemandem hier so ein Kabel zum flashen zur Verfügung?
    Hat jemand schon mal sowas gemacht?

    Leider bin ich jetzt etwas aufgeschmissen und komme nicht weiter
    (Wohl auch, weil Linux für mich ehrlich gesagt ein Buch mit sehr sehr vielen Siegeln ist ;) )

  • Quote

    Als nächstes habe ich das Jetson Nano herunter gefahren (Power-Taste am Case) und wollte es später wieder hochfahren.

    Vermutlich hast du es damit in den tot geschickt.

    Die Belabox musst du über das Webinterface sauber runterfahren.

    In deinem fall rate ich dir die Sd Karte nochmal neu zu flashen.

    wenn der Nano gestartet ist, schau in deinem Router nach welche Ip er hat, und verbinde dich direkt zu ihm.

  • Danke für Deine Rückmeldung

    Vermutlich hast du es damit in den tot geschickt.

    Die Belabox musst du über das Webinterface sauber runterfahren.

    Das einmalige Drücken des PowerTasters löst doch aber das gleiche Event aus (?). Hatte das auch in der Console (Bildschirm war per HDMI angeschlossen) gesehen. Wäre es nicht etwas heftig, wenn ein einmaliges kurzes Drücken des Powertasters das komplette Jetson Nano himmelt?


    In deinem fall rate ich dir die Sd Karte nochmal neu zu flashen.

    wenn der Nano gestartet ist, schau in deinem Router nach welche Ip er hat, und verbinde dich direkt zu ihm.

    Leider bereits getestet. Sowohl verschiedene SK-Cards als auch verschiedene Images (nVidia & Belabox). Das Teil bleibt stumm. Kein EIntrag im Router und auch der Screen vom Bootloader kommt nicht. Laut dem Link (siehe oben) ist quasi der Bootloader zerschossen und kann wiederhergestellt werden, wenn das Teil an einen PC angeschlossen wird und per SDK Manager + Ubintu 18.04 neu geflasht wird.

    Das Problem: Ich habe weder das Kabel (das könnte ich ja besorgen: https://www.reichelt.de/raspberry-pi-u…tl-p150567.html ) noch die Fähigkeiten im Umgang mit Linux und habe darauf gehofft, das jemand hier vielleicht schon mal so einen Fall auf dem Tisch hatte.


    Jetson Nano Console:

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    Edited 2 times, last by Viator (September 4, 2023 at 5:14 PM).

  • bist du dir 100 % sicher, dass du den Powertaster richtig angeschlossen hast?

    Und ich würde da erst mal nichts mit irgendeinem Kabel flashen. Sondern diverse (neue) SD Karten flashen und ausprobieren. Wenn es allerdings mit gar keiner frisch geflashten SD Karte läuft, dann hast du vielleicht doch deinen Jetson gekillt, weil dein PowerButton falsch angeschlossen wurde ... Aber ohne Glaskugel ist ferndiagnose immer schwer ;)

  • Powertaster war zu 100% richtig angeschlossen gewesen. Das Board ließ sich damit im Vorfeld mehrfach mit dem Image von NVidia starten und herunter fahren.

    Und wie gesagt: Auch Belabox zeigte das ordentliche herunterfahren in der Console

    Einen falsch angeschlossenen Powertaster können wir zu 100% ausschließen

  • @Akinos01

    Danke für deinen Post...

    Zu 1)
    Ja - bereits getestet

    Zu 2)

    Ebenfalls bereits getestet (siehe Eröffnungspost). Habe auch ein 5V 8A Netzteil getestet. Und das Teil lief ja bereits...

    Zu 4)

    Ohne Adapter. lief einwandfrei...

    Zu 5)
    Nein - noch nicht... waren aber auch keine USB Geräte angesteckt

    Zu 6)
    Es war eine WLAN-Karte gesteckt. Habe es mit und ohne probiert... macht keinen Unterschied...


    Green light on no display
    Your log shows a repeated QSPI corrupt memory error (see “NvTbootFailControlDoFailover”). This in turn is part of QSPI memory. The background is that SD card…
    forums.developer.nvidia.com

    Es gibt mehrere Leute mit dem gleichen Problem und alle haben sie es auf dem hier und oben in dem Post beschriebenen Weg hinbekommen. Wenn ich es richtig verstanden habe hängt das Teil in einer Art Wiederherstellungsmodus oder so ähnlich und muss neu geflasht werden.

    Das Problem ist einfach, dass ich zu wenig Kenntnis im Umgang mit Linux habe und die Anleitung daher leider nicht anwenden kann. Daher die Frage hier im Forum, ob jemand schon mal damit zu tun hatte...

    Andernfalls kann ich das Teil (wohlwissend, dass es technisch mit hoher Wahrscheinlichkeit i.O. ist) tatsächlich an die Wand nageln, was natürlich ärgerlich ist :thumbdown: ?( :thumbdown:

    Edited 3 times, last by Viator (September 4, 2023 at 11:57 PM).

  • Wenn ich mir die ganze Sache anschaue, sieht das aber gar nicht so schwer aus, da es die ganze Sache auch mit Gui gibt?!

    Setz dir dich mal ein Ubuntu / Debian in einer Vm auf und teste mal.

    Eventuell kannst du dich wenn es soweit ist auch mal im Discord einfinden das du dein Bildschirm Streamst, dann kann man auch zusammen schauen

  • Ubuntu 18.04 (https://releases.ubuntu.com/18.04/ -> Desktop-Image) habe ich eben installiert. Ich muss an der Stelle gestehen, dass die Installation schon komfortabel ist für GUI-Honks wie mich ;)

    Werde jetzt mal testen, wie/ob ich bestimmte USB Geräte über Hyper-V an die VM quasi durchschleifen kann... scheinbar scheint das nicht so trivial zu sein :/

    Kabel (https://www.amazon.de/dp/B09KGQCZ58) habe ich bestellt. Kommt morgen...

    Werde dann mal testen, ob

    Edited once, last by Viator (September 6, 2023 at 10:34 PM).

  • Leider ein bis jetzt nur teilweise positives Ergebnis:

    (1) mit Ubuntu Live lässt sich der nVidia SDK Manager nicht nutzen, weil installiert nicht

    Download funktioneirt aber wenn ich auf "Install" klicke, rödelt in < 1 Sekunde die Fortschrittsanzeige durch und danach steht wieder "Install"

    2) Ubuntu per Virtualbox aufsetzen funktioniert... Werde jetzt versuchen das Jetson Nano mal per USB2TTL Kabel zu verbinden

    Edited 8 times, last by Viator (September 8, 2023 at 4:59 PM).

  • Verbinden per TTL-Kabel zur VirtualBox VM hat funktioniert.

    Habe im Folgenden diese Anleitung verwendet:

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    Es sieht so aus, als würde sich das Jetson nano in einer Art Boot-Loop befinden. Könnt ihr was mit dem Screenshot anfangen?

    Wenn ich das Log richtig interpretiere, dann scheint bei mir der gleiche Fehler vorzuliegen, wie hier beschrieben:

    Green light on no display
    Your log shows a repeated QSPI corrupt memory error (see “NvTbootFailControlDoFailover”). This in turn is part of QSPI memory. The background is that SD card…
    forums.developer.nvidia.com

    Leider werde ich aus der Anleitung nicht schlau...

  • Habe es jetzt 3 mal nach dieser Anleitung probiert:

    Jetson Nano B01 does not boot and LED Green
    OH,Yeah. I fixed them all. I’ll tell you how to do it. Install 18.04 ubuntu to the U disk and start it with the computer.(The 18.04 version is very…
    forums.developer.nvidia.com

    Der Installationsprozess geht am Anfang sehr schnell und wird dann immer langsamer. Am Ende bei 98% sagt er, dass der Installationsprozess zu lange dauert und fragt ob man abbrechen möchte: siehe Screenshot.

    Außerdem finde ich die P3450 Modelnummer die auf meinem Board steht nicht in der Auswahlliste für die Installation

    So langsam habe ich den Eindruck, dass mir jemand sagen möchte: "Lass es einfach bleiben"

  • Hallo Zusammen, ein weiteres letztes Update.

    Das Jetson Nano wurde erfolgreich reanimiert. Habe in den tiefen des nVidia Development Forums einen Hinweis gefunden, dass auch ein anderer User das Problem hatte, dass sich das Jetson Nano nicht über eine VM flashen ließ, obwohl der USB Port an die VM durchgeschliffen wurde, die VM das Jetson Nano über den serielen Port auslesen konnte und der SDK Manager das Jetson Nano gefunden hat. (wer rechnet dann damit, dass es sich nicht flashen lässt?)

    Habe dann auf einem Rechner nativ Ubuntu 18.04 installiert und siehe da - das Jetson Nano wurde korrekt geflasht (Anleitung: https://forums.developer.nvidia.com/t/jetson-nano-…-green/237468/8).

    1. Installiere Ubuntu 18.04 (https://releases.ubuntu.com/18.04/)
    2. Download aktuellen nVidia SDK Manager für Ubuntu (https://developer.nvidia.com/sdk-manager)
    3. Jumper in Port "FRC" und "GND" (Achtung, hier gibt es Unterschiede zwischen A01 und B01)
    4. Jumper in Port J48 (Stromversorgung umschalten -> https://jetsonhacks.com/2019/04/10/jet…use-more-power/)
    5. In meinem Fall habe ich eine mit dem JetsonPack-Image beschriebene SD-Card eingesetzt (https://developer.nvidia.com/embedded/learn…no-devkit#write)
    6. Verbinde HDMI mit Display (nur zur Kontrolle, ist nicht zwingend erforderlich)
    7. Verbinde Jetson Nano per Micro USB mit Ubuntu Host
    8. Stelle Stromversorgung über PowerJack (Rundstecker) her -> Grüne LED muss leuchten
    9. Identifiziere Jetson Nano in nVidia SDK Manager (Step 1) und entferne Jumper "FRC"
    10. Wähle passende Softwarepakete und beginne Download
    11. Wenn abfrage kommt, wie das Jetson geflasht werden soll, wähle "Manuel [Varianbte Jetson Nano" und weiter unten im Formular "Runtime" (ohne User/Passworteingabe)
    12. Beginne Flashvorgang (das dauert ziemlich lange). Der Fashvorgang läuft korrekt, wenn das Log sich stets aktualisier
    13. Am Ende startet das Jetson nano neu und man sieht den nVidia Boot Bildschirm auf dem angeschlossenen Display

    Anschließend Belabox Image auf SD-Card geschrieben, alles zusammengebaut und läuft einwandfrei.

    Auch wenn ich die Lösung am Ende selber gefunden habe, dennoch VIELEN DANK für eure Unterstützung! :thumbup:

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!